CVE-2017-16352
CVE-2017-16352
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GraphicsMagick 1.3.26 is vulnerable to a heap-based buffer overflow vulnerability found in the "Display visual image directory" feature of the DescribeImage() function of the magick/describe.c file. One possible way to trigger the vulnerability is to run the identify command on a specially crafted MIFF format file with the verbose flag.
CVSS 8.8 · High · EPSS 14.5% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
graphicsmagick Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.26-17
Update to 1.3.26-17
graphicsmagick Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.26-17
Update to 1.3.26-17
graphicsmagick Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.26-17
Update to 1.3.26-17
graphicsmagick Ubuntu:Pro:14.04:LTS
- Versions
- 1.3.16-1.1ubuntu2
- 1.3.16-1.1ubuntu3
- 1.3.18-1ubuntu3
- 1.3.18-1ubuntu3.1
- 1.3.18-1ubuntu3.1+esm1
- 1.3.18-1ubuntu3.1+esm2
- 1.3.18-1ubuntu3.1+esm3
- Affected ranges
- ECOSYSTEM: < 1.3.18-1ubuntu3.1+esm4
Update to 1.3.18-1ubuntu3.1+esm4
graphicsmagick Ubuntu:16.04:LTS
- Versions
- 1.3.21-3
- 1.3.23-1
- 1.3.23-1build1
- 1.3.23-1ubuntu0.1
- 1.3.23-1ubuntu0.2
- 1.3.23-1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.3.23-1ubuntu0.4
Update to 1.3.23-1ubuntu0.4
Original sources
- http://www.securityfocus.com/bid/101658
- https://www.exploit-db.com/exploits/43111/
- http://hg.graphicsmagick.org/hg/GraphicsMagick?cmd=changeset%3Bnode=7292230dd185
- https://www.debian.org/security/2018/dsa-4321
- https://lists.debian.org/debian-lts-announce/2018/08/msg00002.html
- https://blogs.securiteam.com/index.php/archives/3494
- https://lists.debian.org/debian-lts-announce/2017/11/msg00002.html
- https://usn.ubuntu.com/4232-1/
- https://nvd.nist.gov/vuln/detail/CVE-2017-16352