p PatchFirst

CVE-2017-16353

CVE-2017-16353

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GraphicsMagick 1.3.26 is vulnerable to a memory information disclosure vulnerability found in the DescribeImage function of the magick/describe.c file, because of a heap-based buffer over-read. The portion of the code containing the vulnerability is responsible for printing the IPTC Profile information contained in the image. This vulnerability can be triggered with a specially crafted MIFF file. There is an out-of-bounds buffer dereference because certain increments are never checked.

CVSS 6.5 · Medium · EPSS 13.7% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • graphicsmagick Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.26-17

    Update to 1.3.26-17

  • graphicsmagick Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.26-17

    Update to 1.3.26-17

  • graphicsmagick Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.26-17

    Update to 1.3.26-17

  • graphicsmagick Ubuntu:Pro:14.04:LTS

    Versions
    • 1.3.16-1.1ubuntu2
    • 1.3.16-1.1ubuntu3
    • 1.3.18-1ubuntu3
    • 1.3.18-1ubuntu3.1
    • 1.3.18-1ubuntu3.1+esm1
    • 1.3.18-1ubuntu3.1+esm2
    • 1.3.18-1ubuntu3.1+esm3
    Affected ranges
    • ECOSYSTEM: < 1.3.18-1ubuntu3.1+esm4

    Update to 1.3.18-1ubuntu3.1+esm4

  • graphicsmagick Ubuntu:16.04:LTS

    Versions
    • 1.3.21-3
    • 1.3.23-1
    • 1.3.23-1build1
    • 1.3.23-1ubuntu0.1
    • 1.3.23-1ubuntu0.2
    • 1.3.23-1ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 1.3.23-1ubuntu0.4

    Update to 1.3.23-1ubuntu0.4

Original sources

Check your server →