CVE-2017-16510
CVE-2017-16510
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress before 4.8.3 is affected by an issue where $wpdb->prepare() can create unexpected and unsafe queries leading to potential SQL injection (SQLi) in plugins and themes, as demonstrated by a "double prepare" approach, a different vulnerability than CVE-2017-14723.
CVSS 9.8 · Critical · EPSS 6.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.3+dfsg-1
Update to 4.8.3+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.3+dfsg-1
Update to 4.8.3+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.8.3+dfsg-1
Update to 4.8.3+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/WordPress/WordPress/commit/a2693fd8602e3263b5925b9d799ddd577202167d
- https://www.debian.org/security/2018/dsa-4090
- https://lists.debian.org/debian-lts-announce/2017/11/msg00003.html
- http://www.securityfocus.com/bid/101638
- https://wpvulndb.com/vulnerabilities/8941
- https://codex.wordpress.org/Version_4.8.3
- https://blog.ircmaxell.com/2017/10/disclosure-wordpress-wpdb-sql-injection-technical.html
- https://wordpress.org/news/2017/10/wordpress-4-8-3-security-release/
- https://nvd.nist.gov/vuln/detail/CVE-2017-16510