CVE-2017-16897
CVE-2017-16897
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).
CVSS 8.1 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
passport-wsfed-saml2 npm
- Affected ranges
- SEMVER: < 3.0.5
Update to 3.0.5