CVE-2017-17094
CVE-2017-17094
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
CVSS 5.4 · Medium · EPSS 2.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.9.1+dfsg-1
Update to 4.9.1+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.9.1+dfsg-1
Update to 4.9.1+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.9.1+dfsg-1
Update to 4.9.1+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://wpvulndb.com/vulnerabilities/8967
- https://www.debian.org/security/2018/dsa-4090
- https://lists.debian.org/debian-lts-announce/2017/12/msg00019.html
- http://www.securityfocus.com/bid/102024
- https://codex.wordpress.org/Version_4.9.1
- https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/
- https://github.com/WordPress/WordPress/commit/f1de7e42df29395c3314bf85bff3d1f4f90541de
- https://nvd.nist.gov/vuln/detail/CVE-2017-17094