CVE-2017-17480
CVE-2017-17480
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In OpenJPEG 2.3.0, a stack-based buffer overflow was discovered in the pgxtovolume function in jp3d/convert.c. The vulnerability causes an out-of-bounds write, which may lead to remote denial of service or possibly remote code execution.
CVSS 9.8 · Critical · EPSS 5.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
openjpeg2 Debian:12
- Affected ranges
- ECOSYSTEM: < 2.3.0-2
Update to 2.3.0-2
openjpeg2 Debian:13
- Affected ranges
- ECOSYSTEM: < 2.3.0-2
Update to 2.3.0-2
openjpeg2 Debian:14
- Affected ranges
- ECOSYSTEM: < 2.3.0-2
Update to 2.3.0-2
openjpeg2 Ubuntu:16.04:LTS
- Versions
- 2.1.0-2.1
- 2.1.0-2.1ubuntu0.1
- 2.1.2-1.1+deb9u2build0.1
- Affected ranges
- ECOSYSTEM: < 2.1.2-1.1+deb9u3build0.16.04.1
Update to 2.1.2-1.1+deb9u3build0.16.04.1
openjpeg2 Ubuntu:18.04:LTS
- Versions
- 2.2.0-1
- 2.3.0-1
- Affected ranges
- ECOSYSTEM: < 2.3.0-2build0.18.04.1
Update to 2.3.0-2build0.18.04.1