p PatchFirst

CVE-2017-17670

CVE-2017-17670

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In VideoLAN VLC media player through 2.2.8, there is a type conversion vulnerability in modules/demux/mp4/libmp4.c in the MP4 demux module leading to a invalid free, because the type of a box may be changed between a read operation and a free operation.

CVSS 8.8 · High · EPSS 2.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • vlc Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.0~rc2-1

    Update to 3.0.0~rc2-1

  • vlc Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.0~rc2-1

    Update to 3.0.0~rc2-1

  • vlc Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.0~rc2-1

    Update to 3.0.0~rc2-1

  • vlc Ubuntu:Pro:16.04:LTS

    Versions
    • 2.2.1-3
    • 2.2.1-5
    • 2.2.2-1
    • 2.2.2-2
    • 2.2.2-3
    • 2.2.2-3build1
    • 2.2.2-4
    • 2.2.2-5
    • 2.2.2-5ubuntu0.16.04.1
    • 2.2.2-5ubuntu0.16.04.2
    • 2.2.2-5ubuntu0.16.04.3
    • 2.2.2-5ubuntu0.16.04.4
    • 2.2.2-5ubuntu0.16.04.5+esm1
    • 2.2.2-5ubuntu0.16.04.5+esm2
    • 2.2.2-5ubuntu0.16.04.5+esm3
    • 2.2.2-5ubuntu0.16.04.5+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →