CVE-2017-17787
CVE-2017-17787
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In GIMP 2.8.22, there is a heap-based buffer over-read in read_creator_block in plug-ins/common/file-psp.c.
CVSS 7.8 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
gimp Debian:12
- Affected ranges
- ECOSYSTEM: < 2.8.20-1.1
Update to 2.8.20-1.1
gimp Debian:13
- Affected ranges
- ECOSYSTEM: < 2.8.20-1.1
Update to 2.8.20-1.1
gimp Debian:14
- Affected ranges
- ECOSYSTEM: < 2.8.20-1.1
Update to 2.8.20-1.1
gimp Ubuntu:14.04:LTS
- Versions
- 2.8.6-1ubuntu1
- 2.8.6-1ubuntu2
- 2.8.6-1ubuntu3
- 2.8.10-0ubuntu1
- 2.8.10-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 2.8.10-0ubuntu1.2
Update to 2.8.10-0ubuntu1.2
gimp Ubuntu:Pro:16.04:LTS
- Versions
- 2.8.14-1ubuntu2
- 2.8.14-1.2ubuntu1
- 2.8.16-1ubuntu1
- 2.8.16-1ubuntu1.1
- 2.8.16-1ubuntu1.1+esm1
- 2.8.16-1ubuntu1.1+esm2
- 2.8.16-1ubuntu1.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published