CVE-2017-17816
CVE-2017-17816
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Netwide Assembler (NASM) 2.14rc0, there is a use-after-free in pp_getline in asm/preproc.c that will cause a remote denial of service attack.
CVSS 5.5 · Medium · EPSS 1.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
nasm Debian:12
- Affected ranges
- ECOSYSTEM: < 2.13.02-0.1
Update to 2.13.02-0.1
nasm Debian:13
- Affected ranges
- ECOSYSTEM: < 2.13.02-0.1
Update to 2.13.02-0.1
nasm Debian:14
- Affected ranges
- ECOSYSTEM: < 2.13.02-0.1
Update to 2.13.02-0.1
nasm Ubuntu:14.04:LTS
- Versions
- 2.10.07-1
- 2.10.09-1
- Affected ranges
- ECOSYSTEM: < 2.10.09-1ubuntu0.1
Update to 2.10.09-1ubuntu0.1
nasm Ubuntu:16.04:LTS
- Versions
- 2.11.06-1really2.11.05-1
- 2.11.08-1
- Affected ranges
- ECOSYSTEM: < 2.11.08-1ubuntu0.1
Update to 2.11.08-1ubuntu0.1