CVE-2017-17913
CVE-2017-17913
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.
CVSS 8.8 · High · EPSS 1.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
graphicsmagick Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.27-3
Update to 1.3.27-3
graphicsmagick Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.27-3
Update to 1.3.27-3
graphicsmagick Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.27-3
Update to 1.3.27-3
graphicsmagick Ubuntu:16.04:LTS
- Versions
- 1.3.21-3
- 1.3.23-1
- 1.3.23-1build1
- 1.3.23-1ubuntu0.1
- 1.3.23-1ubuntu0.2
- 1.3.23-1ubuntu0.3
- 1.3.23-1ubuntu0.4
- 1.3.23-1ubuntu0.5
- Affected ranges
- ECOSYSTEM: < 1.3.23-1ubuntu0.6
Update to 1.3.23-1ubuntu0.6