CVE-2017-18077
CVE-2017-18077
This page contains facts from public vulnerability sources. Check the original advisory before updating.
index.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
CVSS 7.5 · High · EPSS 2.6% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-brace-expansion Debian:12
- Affected ranges
- ECOSYSTEM: < 1.1.8-1
Update to 1.1.8-1
node-brace-expansion Debian:13
- Affected ranges
- ECOSYSTEM: < 1.1.8-1
Update to 1.1.8-1
node-brace-expansion Debian:14
- Affected ranges
- ECOSYSTEM: < 1.1.8-1
Update to 1.1.8-1
brace-expansion npm
- Affected ranges
- SEMVER: < 1.1.7
Update to 1.1.7