CVE-2017-18123
CVE-2017-18123
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The call parameter of /lib/exe/ajax.php in DokuWiki through 2017-02-19e does not properly encode user input, which leads to a reflected file download vulnerability, and allows remote attackers to run arbitrary programs.
CVSS 8.6 · High · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
dokuwiki Debian:12
- Affected ranges
- ECOSYSTEM: < 0.0.20160626.a-2.1
Update to 0.0.20160626.a-2.1
dokuwiki Debian:13
- Affected ranges
- ECOSYSTEM: < 0.0.20160626.a-2.1
Update to 0.0.20160626.a-2.1
dokuwiki Debian:14
- Affected ranges
- ECOSYSTEM: < 0.0.20160626.a-2.1
Update to 0.0.20160626.a-2.1
dokuwiki Ubuntu:16.04:LTS
- Versions
- 0.0.20140929.d-1
- 0.0.20140929.d-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
dokuwiki Ubuntu:18.04:LTS
- Versions
- 0.0.20160626.a-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/splitbrain/dokuwiki/pull/2019
- https://vulnhive.com/2018/000004
- https://lists.debian.org/debian-lts-announce/2018/02/msg00004.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00004.html
- https://github.com/splitbrain/dokuwiki/commit/238b8e878ad48f370903465192b57c2072f65d86
- https://hackerone.com/reports/238316
- https://github.com/splitbrain/dokuwiki/issues/2029
- https://nvd.nist.gov/vuln/detail/CVE-2017-18123