CVE-2017-18214
CVE-2017-18214
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.
CVSS 7.5 · High · EPSS 3.6% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-moment Debian:12
- Affected ranges
- ECOSYSTEM: < 2.19.3+ds-1
Update to 2.19.3+ds-1
node-moment Debian:13
- Affected ranges
- ECOSYSTEM: < 2.19.3+ds-1
Update to 2.19.3+ds-1
node-moment Debian:14
- Affected ranges
- ECOSYSTEM: < 2.19.3+ds-1
Update to 2.19.3+ds-1
moment npm
- Affected ranges
- SEMVER: < 2.19.3
Update to 2.19.3
node-moment Ubuntu:Pro:16.04:LTS
- Versions
- 2.10.6+dfsg-1
- 2.11.0+ds-1
- Affected ranges
- ECOSYSTEM: < 2.11.0+ds-1ubuntu0.1~esm1
Update to 2.11.0+ds-1ubuntu0.1~esm1