CVE-2017-18922
CVE-2017-18922
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It was discovered that websockets.c in LibVNCServer prior to 0.9.12 did not properly decode certain WebSocket frames. A malicious attacker could exploit this by sending specially crafted WebSocket frames to a server, causing a heap-based buffer overflow.
CVSS 9.8 · Critical · EPSS 2.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libvncserver Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-3
Update to 0.9.12+dfsg-3
libvncserver Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-3
Update to 0.9.12+dfsg-3
libvncserver Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-3
Update to 0.9.12+dfsg-3
x11vnc Ubuntu:14.04:LTS
- Versions
- 0.9.13-1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libvncserver Ubuntu:16.04:LTS
- Versions
- 0.9.10+dfsg-3
- 0.9.10+dfsg-3build1
- 0.9.10+dfsg-3ubuntu0.16.04.1
- 0.9.10+dfsg-3ubuntu0.16.04.2
- 0.9.10+dfsg-3ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.4
Update to 0.9.10+dfsg-3ubuntu0.16.04.4
libvncserver Ubuntu:18.04:LTS
- Versions
- 0.9.11+dfsg-1
- 0.9.11+dfsg-1ubuntu1
- 0.9.11+dfsg-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 0.9.11+dfsg-1ubuntu1.2
Update to 0.9.11+dfsg-1ubuntu1.2
libvncserver Ubuntu:20.04:LTS
- Versions
- 0.9.11+dfsg-1.3
- 0.9.12+dfsg-3ubuntu3
- 0.9.12+dfsg-6
- 0.9.12+dfsg-7
- 0.9.12+dfsg-8
- 0.9.12+dfsg-9
- Affected ranges
- ECOSYSTEM: < 0.9.12+dfsg-9ubuntu0.1
Update to 0.9.12+dfsg-9ubuntu0.1
veyon Ubuntu:20.04:LTS
- Versions
- 4.2.4+repack1-2
- 4.2.5+repack1-1
- 4.3.1+repack1-1
- 4.3.1+repack1-2
- 4.3.1+repack1-2build1
- 4.3.1+repack1-2build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
veyon Ubuntu:22.04:LTS
- Versions
- 4.5.3+repack1-1build1
- 4.5.3+repack1-1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
veyon Ubuntu:24.04:LTS
- Versions
- 4.7.5+repack1-1build2
- 4.7.5+repack1-1ubuntu1
- 4.7.5+repack1-1ubuntu3
- 4.7.5+repack1-1ubuntu4
- 4.7.5+repack1-1ubuntu5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
veyon Ubuntu:25.10
- Versions
- 4.7.5+repack1-1ubuntu6
- 4.7.5+repack1-1ubuntu7
- 4.9.7+repack1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
veyon Ubuntu:26.10
- Versions
- 4.9.7+repack1-1build1
- 4.9.7+repack1-1.1
- 4.9.7+repack1-1.1build1
- 4.9.7+repack1-1.1build2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
veyon Ubuntu:26.04:LTS
- Versions
- 4.9.7+repack1-1
- 4.9.7+repack1-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/LibVNC/libvncserver/commit/aac95a9dcf4bbba87b76c72706c3221a842ca433
- https://www.openwall.com/lists/oss-security/2020/06/30/2
- https://bugzilla.redhat.com/show_bug.cgi?id=1852356
- http://www.openwall.com/lists/oss-security/2020/06/30/3
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00020.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NVP7TJVYJDXDFRHVQ3ENEN3H354QPXEZ/
- https://usn.ubuntu.com/4407-1/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4F6FUH4EFK4NAP6GT4TQRTBKWIRCZLIY/
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00028.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00033.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00055.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00066.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-390195.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2017-18922