p PatchFirst

CVE-2017-2518

CVE-2017-2518

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An issue was discovered in certain Apple products. iOS before 10.3.2 is affected. macOS before 10.12.5 is affected. tvOS before 10.2.1 is affected. watchOS before 3.2.2 is affected. The issue involves the "SQLite" component. It allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a crafted SQL statement.

CVSS 9.8 · Critical · EPSS 5.3% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • sqlite3 Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.15.2-1

    Update to 3.15.2-1

  • sqlite3 Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.15.2-1

    Update to 3.15.2-1

  • sqlite3 Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.15.2-1

    Update to 3.15.2-1

  • sqlite3 Ubuntu:Pro:14.04:LTS

    Versions
    • 3.7.17-1ubuntu1
    • 3.8.0.2-1ubuntu1
    • 3.8.1-1ubuntu1
    • 3.8.1-1ubuntu3
    • 3.8.2-1ubuntu1
    • 3.8.2-1ubuntu2
    • 3.8.2-1ubuntu2.1
    • 3.8.2-1ubuntu2.2
    Affected ranges
    • ECOSYSTEM: < 3.8.2-1ubuntu2.2+esm1

    Update to 3.8.2-1ubuntu2.2+esm1

  • sqlite3 Ubuntu:16.04:LTS

    Versions
    • 3.8.11.1-1
    • 3.9.1-2
    • 3.9.2-1
    • 3.10.0-1
    • 3.10.1-1
    • 3.10.2-1
    • 3.11.0-1ubuntu1
    • 3.11.0-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 3.11.0-1ubuntu1.2

    Update to 3.11.0-1ubuntu1.2

Original sources

Check your server →