CVE-2017-2576
CVE-2017-2576
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Moodle 2.x and 3.x, there is incorrect sanitization of attributes in forums.
CVSS 5.3 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
moodle 2.x and 3.x
- Versions
- Moodle 2.x and 3.x: Affected
No fix published
moodle/moodle Packagist
- Versions
- v2.7.0
- v2.7.0-beta
- v2.7.0-rc1
- v2.7.0-rc2
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.12
- v2.7.13
- v2.7.14
- v2.7.15
- v2.7.16
- v2.7.17
- v2.7.2
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- Affected ranges
- ECOSYSTEM: ≥ 2.7, < 2.7.18
Update to 2.7.18
moodle/moodle Packagist
- Versions
- v3.0.0
- v3.0.0-beta
- v3.0.0-rc1
- v3.0.0-rc2
- v3.0.0-rc3
- v3.0.0-rc4
- v3.0.1
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- Affected ranges
- ECOSYSTEM: ≥ 3.0, < 3.0.8
Update to 3.0.8
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.2
- v3.1.3
- Affected ranges
- ECOSYSTEM: ≥ 3.1, < 3.1.4
Update to 3.1.4
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.0-beta
- v3.2.0-rc1
- v3.2.0-rc2
- v3.2.0-rc3
- v3.2.0-rc4
- v3.2.0-rc5
- Affected ranges
- ECOSYSTEM: ≥ 3.2, < 3.2.1
Update to 3.2.1
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published