CVE-2017-2615
CVE-2017-2615
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Quick emulator (QEMU) built with the Cirrus CLGD 54xx VGA emulator support is vulnerable to an out-of-bounds access issue. It could occur while copying VGA data via bitblt copy in backward mode. A privileged user inside a guest could use this flaw to crash the QEMU process resulting in DoS or potentially execute arbitrary code on the host with privileges of QEMU process on the host.
CVSS 5.5 · Medium · EPSS 3.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
display
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.8+dfsg-3
Update to 1:2.8+dfsg-3
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.8+dfsg-3
Update to 1:2.8+dfsg-3
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.8+dfsg-3
Update to 1:2.8+dfsg-3
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- 2.0.0+dfsg-2ubuntu1.11
- 2.0.0+dfsg-2ubuntu1.13
- 2.0.0+dfsg-2ubuntu1.14
- 2.0.0+dfsg-2ubuntu1.15
- 2.0.0+dfsg-2ubuntu1.16
- 2.0.0+dfsg-2ubuntu1.17
- 2.0.0+dfsg-2ubuntu1.18
- 2.0.0+dfsg-2ubuntu1.19
- 2.0.0+dfsg-2ubuntu1.20
- 2.0.0+dfsg-2ubuntu1.21
- 2.0.0+dfsg-2ubuntu1.22
- 2.0.0+dfsg-2ubuntu1.24
- 2.0.0+dfsg-2ubuntu1.25
- 2.0.0+dfsg-2ubuntu1.26
- 2.0.0+dfsg-2ubuntu1.27
- 2.0.0+dfsg-2ubuntu1.28
- 2.0.0+dfsg-2ubuntu1.29
- 2.0.0+dfsg-2ubuntu1.30
- 2.0.0+dfsg-2ubuntu1.31
- 2.0.0+dfsg-2ubuntu1.32
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.33
Update to 2.0.0+dfsg-2ubuntu1.33
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- 4.4.1-0ubuntu0.14.04.2
- 4.4.1-0ubuntu0.14.04.3
- 4.4.1-0ubuntu0.14.04.4
- 4.4.1-0ubuntu0.14.04.5
- 4.4.1-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.1
- 4.4.2-0ubuntu0.14.04.2
- 4.4.2-0ubuntu0.14.04.3
- 4.4.2-0ubuntu0.14.04.4
- 4.4.2-0ubuntu0.14.04.5
- 4.4.2-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.7
- 4.4.2-0ubuntu0.14.04.9
- 4.4.2-0ubuntu0.14.04.10
- Affected ranges
- ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.11
Update to 4.4.2-0ubuntu0.14.04.11
qemu Ubuntu:16.04:LTS
- Versions
- 1:2.3+dfsg-5ubuntu9
- 1:2.3+dfsg-5ubuntu10
- 1:2.4+dfsg-4ubuntu1
- 1:2.4+dfsg-4ubuntu2
- 1:2.4+dfsg-4ubuntu3
- 1:2.4+dfsg-5ubuntu3
- 1:2.5+dfsg-1ubuntu2
- 1:2.5+dfsg-1ubuntu3
- 1:2.5+dfsg-1ubuntu4
- 1:2.5+dfsg-1ubuntu5
- 1:2.5+dfsg-5ubuntu1
- 1:2.5+dfsg-5ubuntu2
- 1:2.5+dfsg-5ubuntu4
- 1:2.5+dfsg-5ubuntu6
- 1:2.5+dfsg-5ubuntu7
- 1:2.5+dfsg-5ubuntu10
- 1:2.5+dfsg-5ubuntu10.1
- 1:2.5+dfsg-5ubuntu10.2
- 1:2.5+dfsg-5ubuntu10.3
- 1:2.5+dfsg-5ubuntu10.4
- 1:2.5+dfsg-5ubuntu10.5
- 1:2.5+dfsg-5ubuntu10.6
- 1:2.5+dfsg-5ubuntu10.7
- 1:2.5+dfsg-5ubuntu10.8
- 1:2.5+dfsg-5ubuntu10.9
- 1:2.5+dfsg-5ubuntu10.10
- Affected ranges
- ECOSYSTEM: < 1:2.5+dfsg-5ubuntu10.11
Update to 1:2.5+dfsg-5ubuntu10.11
Original sources
- http://rhn.redhat.com/errata/RHSA-2017-0329.html
- http://rhn.redhat.com/errata/RHSA-2017-0334.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2615
- http://www.securitytracker.com/id/1037804
- http://rhn.redhat.com/errata/RHSA-2017-0328.html
- https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
- http://www.securityfocus.com/bid/95990
- http://rhn.redhat.com/errata/RHSA-2017-0333.html
- https://security.gentoo.org/glsa/201702-27
- http://www.openwall.com/lists/oss-security/2017/02/01/6
- http://rhn.redhat.com/errata/RHSA-2017-0454.html
- https://lists.gnu.org/archive/html/qemu-devel/2017-02/msg00015.html
- http://rhn.redhat.com/errata/RHSA-2017-0331.html
- https://security.gentoo.org/glsa/201702-28
- http://rhn.redhat.com/errata/RHSA-2017-0350.html
- http://rhn.redhat.com/errata/RHSA-2017-0396.html
- http://rhn.redhat.com/errata/RHSA-2017-0309.html
- http://rhn.redhat.com/errata/RHSA-2017-0344.html
- http://rhn.redhat.com/errata/RHSA-2017-0330.html
- http://rhn.redhat.com/errata/RHSA-2017-0332.html
- https://support.citrix.com/article/CTX220771
- https://nvd.nist.gov/vuln/detail/CVE-2017-2615