CVE-2017-2619
CVE-2017-2619
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Samba before versions 4.6.1, 4.5.7 and 4.4.11 are vulnerable to a malicious client using a symlink race to allow access to areas of the server file system not exported under the share definition.
CVSS 7.5 · High · EPSS 11.1% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
samba
- Versions
- 4.6.1: Affected
- 4.5.7: Affected
- 4.4.11: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.5.6+dfsg-2
Update to 2:4.5.6+dfsg-2
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.5.6+dfsg-2
Update to 2:4.5.6+dfsg-2
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.5.6+dfsg-2
Update to 2:4.5.6+dfsg-2
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- 2:4.3.8+dfsg-0ubuntu0.14.04.2
- 2:4.3.9+dfsg-0ubuntu0.14.04.1
- 2:4.3.9+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.1
- 2:4.3.11+dfsg-0ubuntu0.14.04.2
- 2:4.3.11+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.4
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.14.04.6
Update to 2:4.3.11+dfsg-0ubuntu0.14.04.6
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- 2:4.3.8+dfsg-0ubuntu1
- 2:4.3.9+dfsg-0ubuntu0.16.04.1
- 2:4.3.9+dfsg-0ubuntu0.16.04.2
- 2:4.3.9+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.1
- 2:4.3.11+dfsg-0ubuntu0.16.04.3
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.16.04.5
Update to 2:4.3.11+dfsg-0ubuntu0.16.04.5
Original sources
- https://access.redhat.com/errata/RHSA-2017:2778
- https://www.debian.org/security/2017/dsa-3816
- http://www.securityfocus.com/bid/97033
- https://www.exploit-db.com/exploits/41740/
- http://www.securitytracker.com/id/1038117
- https://access.redhat.com/errata/RHSA-2017:2338
- https://www.samba.org/samba/security/CVE-2017-2619.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1429472
- https://access.redhat.com/errata/RHSA-2017:1265
- https://access.redhat.com/errata/RHSA-2017:2789
- https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbns03755en_us
- https://nvd.nist.gov/vuln/detail/CVE-2017-2619