CVE-2017-2640
CVE-2017-2640
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An out-of-bounds write flaw was found in the way Pidgin before 2.12.0 processed XML content. A malicious remote server could potentially use this flaw to crash Pidgin or execute arbitrary code in the context of the pidgin process.
CVSS 7.5 · High · EPSS 6.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
pidgin
- Versions
- 2.12.0: Affected
No fix published
pidgin Debian:12
- Affected ranges
- ECOSYSTEM: < 2.12.0-1
Update to 2.12.0-1
pidgin Debian:13
- Affected ranges
- ECOSYSTEM: < 2.12.0-1
Update to 2.12.0-1
pidgin Debian:14
- Affected ranges
- ECOSYSTEM: < 2.12.0-1
Update to 2.12.0-1
pidgin Ubuntu:14.04:LTS
- Versions
- 1:2.10.7-0ubuntu4.1
- 1:2.10.7-0ubuntu4.2
- 1:2.10.9-0ubuntu1
- 1:2.10.9-0ubuntu2
- 1:2.10.9-0ubuntu3
- 1:2.10.9-0ubuntu3.1
- 1:2.10.9-0ubuntu3.2
- 1:2.10.9-0ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 1:2.10.9-0ubuntu3.4
Update to 1:2.10.9-0ubuntu3.4
pidgin Ubuntu:16.04:LTS
- Versions
- 1:2.10.11-0ubuntu4
- 1:2.10.11-0ubuntu5
- 1:2.10.12-0ubuntu1
- 1:2.10.12-0ubuntu2
- 1:2.10.12-0ubuntu3
- 1:2.10.12-0ubuntu4
- 1:2.10.12-0ubuntu5
- 1:2.10.12-0ubuntu5.1
- Affected ranges
- ECOSYSTEM: < 1:2.10.12-0ubuntu5.2
Update to 1:2.10.12-0ubuntu5.2