CVE-2017-2641
CVE-2017-2641
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Moodle 2.x and 3.x, SQL injection can occur via user preferences.
CVSS 9.8 · Critical · EPSS 14.5% · Public exploit · Fix available
- Published
- Updated
Stack: php
Affected products and versions
moodle 2.x and 3.x
- Versions
- Moodle 2.x and 3.x: Affected
No fix published
moodle/moodle Packagist
- Versions
- v2.7.0
- v2.7.0-beta
- v2.7.0-rc1
- v2.7.0-rc2
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.12
- v2.7.13
- v2.7.14
- v2.7.15
- v2.7.16
- v2.7.17
- v2.7.18
- v2.7.2
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- Affected ranges
- ECOSYSTEM: ≥ 2.7, < 2.7.19
Update to 2.7.19
moodle/moodle Packagist
- Versions
- v3.0.0
- v3.0.0-beta
- v3.0.0-rc1
- v3.0.0-rc2
- v3.0.0-rc3
- v3.0.0-rc4
- v3.0.1
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- v3.0.8
- Affected ranges
- ECOSYSTEM: ≥ 3.0, < 3.0.9
Update to 3.0.9
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.2
- v3.1.3
- v3.1.4
- Affected ranges
- ECOSYSTEM: ≥ 3.1, < 3.1.5
Update to 3.1.5
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.0-beta
- v3.2.0-rc1
- v3.2.0-rc2
- v3.2.0-rc3
- v3.2.0-rc4
- v3.2.0-rc5
- v3.2.1
- Affected ranges
- ECOSYSTEM: ≥ 3.2, < 3.2.2
Update to 3.2.2