p PatchFirst

CVE-2017-2645

CVE-2017-2645

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Moodle 3.x, XSS can occur via attachments to evidence of prior learning.

CVSS 6.1 · Medium · EPSS 1.1% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • moodle 3.x

    Versions
    • Moodle 3.x: Affected

    No fix published

  • moodle/moodle Packagist

    Versions
    • v3.1.0
    • v3.1.0-beta
    • v3.1.0-rc1
    • v3.1.0-rc2
    • v3.1.1
    • v3.1.2
    • v3.1.3
    • v3.1.4
    Affected ranges
    • ECOSYSTEM: ≥ 3.1, < 3.1.5

    Update to 3.1.5

  • moodle/moodle Packagist

    Versions
    • v3.2.0
    • v3.2.0-beta
    • v3.2.0-rc1
    • v3.2.0-rc2
    • v3.2.0-rc3
    • v3.2.0-rc4
    • v3.2.0-rc5
    • v3.2.1
    Affected ranges
    • ECOSYSTEM: ≥ 3.2, < 3.2.2

    Update to 3.2.2

Original sources

Check your server →