CVE-2017-2800
CVE-2017-2800
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A specially crafted x509 certificate can cause a single out of bounds byte overwrite in wolfSSL through 3.10.2 resulting in potential certificate validation vulnerabilities, denial of service and possible remote code execution. In order to trigger this vulnerability, the attacker needs to supply a malicious x509 certificate to either a server or a client application using this library.
CVSS 8.1 · High · EPSS 8.5% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wolfssl
- Versions
- 3.10.2: Affected
No fix published
wolfssl Debian:12
- Affected ranges
- ECOSYSTEM: < 3.12.0+dfsg-1
Update to 3.12.0+dfsg-1
wolfssl Debian:13
- Affected ranges
- ECOSYSTEM: < 3.12.0+dfsg-1
Update to 3.12.0+dfsg-1
wolfssl Ubuntu:16.04:LTS
- Versions
- 3.4.8+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published