CVE-2017-2810
CVE-2017-2810
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An exploitable vulnerability exists in the Databook loading functionality of Tablib 0.11.4. A yaml loaded Databook can execute arbitrary python commands resulting in command execution. An attacker can insert python into loaded yaml to trigger this vulnerability.
CVSS 7.5 · High · EPSS 4.9% · Fix available
- Published
- Updated
Affected products and versions
tablib
- Versions
- 0.11.4: Affected
No fix published
python-tablib Debian:12
- Affected ranges
- ECOSYSTEM: < 0.9.11-3
Update to 0.9.11-3
python-tablib Debian:13
- Affected ranges
- ECOSYSTEM: < 0.9.11-3
Update to 0.9.11-3
python-tablib Debian:14
- Affected ranges
- ECOSYSTEM: < 0.9.11-3
Update to 0.9.11-3
tablib PyPI
- Versions
- 0.0.1
- 0.10.0
- 0.11.0
- 0.11.1
- 0.11.2
- 0.11.3
- 0.11.4
- 0.6.1
- 0.6.2
- 0.6.3
- 0.6.4
- 0.7.0
- 0.7.1
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.9.0
- 0.9.1
- 0.9.10
- 0.9.11
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- Affected ranges
- ECOSYSTEM: < 0.11.5
Update to 0.11.5
python-tablib Ubuntu:16.04:LTS
- Versions
- 0.9.11-2build1
- Affected ranges
- ECOSYSTEM: < 0.9.11-2+deb9u1build0.16.04.1
Update to 0.9.11-2+deb9u1build0.16.04.1