CVE-2017-2837
CVE-2017-2837
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An exploitable denial of service vulnerability exists within the handling of security data in FreeRDP 2.0.0-beta1+android11. A specially crafted challenge packet can cause the program termination leading to a denial of service condition. An attacker can compromise the server or use man in the middle to trigger this vulnerability.
CVSS 6.5 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
freerdp
- Versions
- 2.0.0-beta1+android11 - Windows, OSX, Linux: Affected
No fix published
freerdp Ubuntu:14.04:LTS
- Versions
- 1.0.2-1ubuntu1
- 1.0.2-2ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.0.2-2ubuntu1.1
Update to 1.0.2-2ubuntu1.1
freerdp Ubuntu:16.04:LTS
- Versions
- 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
Update to 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2