CVE-2017-2887
CVE-2017-2887
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An exploitable buffer overflow vulnerability exists in the XCF property handling functionality of SDL_image 2.0.1. A specially crafted xcf file can cause a stack-based buffer overflow resulting in potential code execution. An attacker can provide a specially crafted XCF file to trigger this vulnerability.
CVSS 8.8 · High · EPSS 2.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
simple direct media
- Versions
- Simple DirectMedia Layer SDL_image 2.0.1: Affected
No fix published
libsdl2-image Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.1+dfsg-4
Update to 2.0.1+dfsg-4
libsdl2-image Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.1+dfsg-4
Update to 2.0.1+dfsg-4
libsdl2-image Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.1+dfsg-4
Update to 2.0.1+dfsg-4
sdl-image1.2 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.2.12-7
Update to 1.2.12-7
sdl-image1.2 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.2.12-7
Update to 1.2.12-7
sdl-image1.2 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.2.12-7
Update to 1.2.12-7
libsdl2-image Ubuntu:14.04:LTS
- Versions
- 2.0.0+dfsg-2
- 2.0.0+dfsg-3
- 2.0.0+dfsg-3build2
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-3+deb8u1build0.14.04.1
Update to 2.0.0+dfsg-3+deb8u1build0.14.04.1
sdl-image1.2 Ubuntu:14.04:LTS
- Versions
- 1.2.12-4ubuntu1
- 1.2.12-5
- 1.2.12-5build2
- Affected ranges
- ECOSYSTEM: < 1.2.12-5+deb9u1build0.14.04.1
Update to 1.2.12-5+deb9u1build0.14.04.1
libsdl2-image Ubuntu:16.04:LTS
- Versions
- 2.0.0+dfsg-3build2
- 2.0.1+dfsg-1
- 2.0.1+dfsg-2
- Affected ranges
- ECOSYSTEM: < 2.0.1+dfsg-2+deb9u1build0.16.04.1
Update to 2.0.1+dfsg-2+deb9u1build0.16.04.1
sdl-image1.2 Ubuntu:16.04:LTS
- Versions
- 1.2.12-5build2
- Affected ranges
- ECOSYSTEM: < 1.2.12-5+deb9u1build0.16.04.1
Update to 1.2.12-5+deb9u1build0.16.04.1