p PatchFirst

CVE-2017-2921

CVE-2017-2921

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An exploitable memory corruption vulnerability exists in the Websocket protocol implementation of Cesanta Mongoose 6.8. A specially crafted websocket packet can cause an integer overflow, leading to a heap buffer overflow and resulting in denial of service and potential remote code execution. An attacker needs to send a specially crafted websocket packet over network to trigger this vulnerability.

CVSS 8.1 · High · EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • mongoose

    Versions
    • 6.8: Affected

    No fix published

  • smplayer Debian:12

    Affected ranges
    • ECOSYSTEM: < 18.5.0~ds1-1

    Update to 18.5.0~ds1-1

  • smplayer Debian:13

    Affected ranges
    • ECOSYSTEM: < 18.5.0~ds1-1

    Update to 18.5.0~ds1-1

  • smplayer Debian:14

    Affected ranges
    • ECOSYSTEM: < 18.5.0~ds1-1

    Update to 18.5.0~ds1-1

Original sources

Check your server →