p PatchFirst

CVE-2017-3305

CVE-2017-3305

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: C API). Supported versions that are affected are 5.5.55 and earlier and 5.6.35 and earlier. Difficult to exploit vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized access to critical data or complete access to all MySQL Server accessible data. CVSS 3.0 Base Score 5.3 (Confidentiality impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N). NOTE: the previous information is from the April 2017 CPU. Oracle has not commented on third-party claims that this issue allows man-in-the-middle attackers to hijack the authentication of users by leveraging incorrect ordering of security parameter verification in a client, aka, "The Riddle".

CVSS 5.3 · Medium · EPSS 1.4% · Fix available

Published
Updated

Stack: system · database

Affected products and versions

  • mysql

    Versions
    • 5.5.55 and earlier: Affected
    • 5.6.35 and earlier: Affected

    No fix published

  • mysql-5.5 Ubuntu:14.04:LTS

    Versions
    • 5.5.32-0ubuntu7
    • 5.5.34-0ubuntu1
    • 5.5.34-0ubuntu2
    • 5.5.35-0ubuntu1
    • 5.5.35+dfsg-1ubuntu1
    • 5.5.37-0ubuntu0.14.04.1
    • 5.5.38-0ubuntu0.14.04.1
    • 5.5.40-0ubuntu0.14.04.1
    • 5.5.41-0ubuntu0.14.04.1
    • 5.5.43-0ubuntu0.14.04.1
    • 5.5.44-0ubuntu0.14.04.1
    • 5.5.46-0ubuntu0.14.04.2
    • 5.5.47-0ubuntu0.14.04.1
    • 5.5.49-0ubuntu0.14.04.1
    • 5.5.50-0ubuntu0.14.04.1
    • 5.5.52-0ubuntu0.14.04.1
    • 5.5.53-0ubuntu0.14.04.1
    • 5.5.54-0ubuntu0.14.04.1
    Affected ranges
    • ECOSYSTEM: < 5.5.55-0ubuntu0.14.04.1

    Update to 5.5.55-0ubuntu0.14.04.1

  • percona-server-5.6 Ubuntu:16.04:LTS

    Versions
    • 5.6.22-rel71.0-0ubuntu2
    • 5.6.22-rel71.0-0ubuntu4
    • 5.6.22-rel71.0-0ubuntu4.1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • percona-xtradb-cluster-5.6 Ubuntu:16.04:LTS

    Versions
    • 5.6.21-25.8-0ubuntu2
    • 5.6.21-25.8-0ubuntu3
    • 5.6.21-25.8-0ubuntu3.1
    • 5.6.21-25.8-0ubuntu3.2
    • 5.6.34-26.19-0ubuntu0.16.04.1
    • 5.6.34-26.19-0ubuntu0.16.04.2
    • 5.6.37-26.21-0ubuntu0.16.04.1
    • 5.6.37-26.21-0ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →