CVE-2017-3651
CVE-2017-3651
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Client mysqldump). Supported versions that are affected are 5.5.56 and earlier, 5.6.36 and earlier and 5.7.18 and earlier. Easily exploitable vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.0 Base Score 4.3 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N).
CVSS 4.3 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Affected products and versions
mysql
- Versions
- 5.5.56 and earlier: Affected
- 5.6.36 and earlier: Affected
- 5.7.18 and earlier: Affected
No fix published
mariadb-5.5 Ubuntu:14.04:LTS
- Versions
- 5.5.32-1ubuntu1
- 5.5.35-1ubuntu1
- 5.5.36-1
- 5.5.37-0ubuntu0.14.04.1
- 5.5.39-0ubuntu0.14.04.1
- 5.5.40-0ubuntu0.14.04.1
- 5.5.41-0ubuntu0.14.04.2
- 5.5.41-1ubuntu0.14.04.1
- 5.5.43-1ubuntu0.14.04.2
- 5.5.44-1ubuntu0.14.04.1
- 5.5.46-1ubuntu0.14.04.2
- 5.5.47-1ubuntu0.14.04.1
- 5.5.49-1ubuntu0.14.04.1
- 5.5.52-1ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.5.53-1ubuntu0.14.04.1
Update to 5.5.53-1ubuntu0.14.04.1
mysql-5.5 Ubuntu:14.04:LTS
- Versions
- 5.5.32-0ubuntu7
- 5.5.34-0ubuntu1
- 5.5.34-0ubuntu2
- 5.5.35-0ubuntu1
- 5.5.35+dfsg-1ubuntu1
- 5.5.37-0ubuntu0.14.04.1
- 5.5.38-0ubuntu0.14.04.1
- 5.5.40-0ubuntu0.14.04.1
- 5.5.41-0ubuntu0.14.04.1
- 5.5.43-0ubuntu0.14.04.1
- 5.5.44-0ubuntu0.14.04.1
- 5.5.46-0ubuntu0.14.04.2
- 5.5.47-0ubuntu0.14.04.1
- 5.5.49-0ubuntu0.14.04.1
- 5.5.50-0ubuntu0.14.04.1
- 5.5.52-0ubuntu0.14.04.1
- 5.5.53-0ubuntu0.14.04.1
- 5.5.54-0ubuntu0.14.04.1
- 5.5.55-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 5.5.57-0ubuntu0.14.04.1
Update to 5.5.57-0ubuntu0.14.04.1
mysql-5.7 Ubuntu:16.04:LTS
- Versions
- 5.7.11-0ubuntu4
- 5.7.11-0ubuntu5
- 5.7.11-0ubuntu6
- 5.7.12-0ubuntu1
- 5.7.12-0ubuntu1.1
- 5.7.13-0ubuntu0.16.04.2
- 5.7.15-0ubuntu0.16.04.1
- 5.7.16-0ubuntu0.16.04.1
- 5.7.17-0ubuntu0.16.04.1
- 5.7.17-0ubuntu0.16.04.2
- 5.7.18-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 5.7.19-0ubuntu0.16.04.1
Update to 5.7.19-0ubuntu0.16.04.1
percona-server-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.22-rel71.0-0ubuntu2
- 5.6.22-rel71.0-0ubuntu4
- 5.6.22-rel71.0-0ubuntu4.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
percona-xtradb-cluster-5.6 Ubuntu:16.04:LTS
- Versions
- 5.6.21-25.8-0ubuntu2
- 5.6.21-25.8-0ubuntu3
- 5.6.21-25.8-0ubuntu3.1
- 5.6.21-25.8-0ubuntu3.2
- 5.6.34-26.19-0ubuntu0.16.04.1
- 5.6.34-26.19-0ubuntu0.16.04.2
- 5.6.37-26.21-0ubuntu0.16.04.1
- 5.6.37-26.21-0ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mysql-5.7 Ubuntu:18.04:LTS
- Affected ranges
- ECOSYSTEM: < 5.7.19-0ubuntu1
Update to 5.7.19-0ubuntu1
Original sources
- https://access.redhat.com/errata/RHSA-2017:2787
- https://access.redhat.com/errata/RHSA-2018:2729
- http://www.securitytracker.com/id/1038928
- http://www.securityfocus.com/bid/99802
- http://rhn.redhat.com/errata/RHSA-2016-2927.html
- https://access.redhat.com/errata/RHSA-2018:2439
- http://www.debian.org/security/2017/dsa-3922
- https://access.redhat.com/errata/RHSA-2017:2886
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- http://rhn.redhat.com/errata/RHSA-2016-2928.html
- https://access.redhat.com/errata/RHSA-2017:2192
- https://nvd.nist.gov/vuln/detail/CVE-2017-3651