CVE-2017-5225
CVE-2017-5225
This page contains facts from public vulnerability sources. Check the original advisory before updating.
LibTIFF version 4.0.7 is vulnerable to a heap buffer overflow in the tools/tiffcp resulting in DoS or code execution via a crafted BitsPerSample value.
CVSS 8.8 · High · EPSS 4.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
tiff Debian:12
- Affected ranges
- ECOSYSTEM: < 4.0.7-5
Update to 4.0.7-5
tiff Debian:13
- Affected ranges
- ECOSYSTEM: < 4.0.7-5
Update to 4.0.7-5
tiff Debian:14
- Affected ranges
- ECOSYSTEM: < 4.0.7-5
Update to 4.0.7-5
tiff Ubuntu:14.04:LTS
- Versions
- 4.0.2-4ubuntu3
- 4.0.3-5ubuntu1
- 4.0.3-6
- 4.0.3-6ubuntu1
- 4.0.3-7
- 4.0.3-7ubuntu0.1
- 4.0.3-7ubuntu0.2
- 4.0.3-7ubuntu0.3
- 4.0.3-7ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 4.0.3-7ubuntu0.6
Update to 4.0.3-7ubuntu0.6
tiff Ubuntu:16.04:LTS
- Versions
- 4.0.3-12.3ubuntu2
- 4.0.5-1
- 4.0.6-1
- Affected ranges
- ECOSYSTEM: < 4.0.6-1ubuntu0.1
Update to 4.0.6-1ubuntu0.1
Original sources
- http://www.debian.org/security/2017/dsa-3844
- https://security.gentoo.org/glsa/201709-27
- http://bugzilla.maptools.org/show_bug.cgi?id=2656
- http://bugzilla.maptools.org/show_bug.cgi?id=2657
- http://www.securitytracker.com/id/1037911
- http://www.securityfocus.com/bid/95413
- https://github.com/vadz/libtiff/commit/5c080298d59efa53264d7248bbe3a04660db6ef7
- https://nvd.nist.gov/vuln/detail/CVE-2017-5225