CVE-2017-5340
CVE-2017-5340
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Zend/zend_hash.c in PHP before 7.0.15 and 7.1.x before 7.1.1 mishandles certain cases that require large array allocations, which allows remote attackers to execute arbitrary code or cause a denial of service (integer overflow, uninitialized memory access, and use of arbitrary destructor function pointers) via crafted serialized data.
CVSS 9.8 · Critical · EPSS 16.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php7.0 Ubuntu:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 7.0.15-0ubuntu0.16.04.2
Update to 7.0.15-0ubuntu0.16.04.2
Original sources
- https://github.com/php/php-src/commit/4cc0286f2f3780abc6084bcdae5dce595daa3c12
- https://access.redhat.com/errata/RHSA-2018:1296
- https://security.netapp.com/advisory/ntap-20180112-0001/
- http://www.securityfocus.com/bid/95371
- https://bugs.php.net/bug.php?id=73832
- http://www.securitytracker.com/id/1037659
- https://nvd.nist.gov/vuln/detail/CVE-2017-5340