CVE-2017-5493
CVE-2017-5493
This page contains facts from public vulnerability sources. Check the original advisory before updating.
wp-includes/ms-functions.php in the Multisite WordPress API in WordPress before 4.7.1 does not properly choose random numbers for keys, which makes it easier for remote attackers to bypass intended access restrictions via a crafted (1) site signup or (2) user signup.
CVSS 7.5 · High · EPSS 2.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.7.1+dfsg-1
Update to 4.7.1+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.7.1+dfsg-1
Update to 4.7.1+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.7.1+dfsg-1
Update to 4.7.1+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://wpvulndb.com/vulnerabilities/8721
- http://www.securityfocus.com/bid/95401
- http://www.debian.org/security/2017/dsa-3779
- https://codex.wordpress.org/Version_4.7.1
- http://www.openwall.com/lists/oss-security/2017/01/14/6
- http://www.securitytracker.com/id/1037591
- https://github.com/WordPress/WordPress/commit/cea9e2dc62abf777e06b12ec4ad9d1aaa49b29f4
- https://wordpress.org/news/2017/01/wordpress-4-7-1-security-and-maintenance-release/
- https://nvd.nist.gov/vuln/detail/CVE-2017-5493