p PatchFirst

CVE-2017-5601

CVE-2017-5601

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An error in the lha_read_file_header_1() function (archive_read_support_format_lha.c) in libarchive 3.2.2 allows remote attackers to trigger an out-of-bounds read memory access and subsequently cause a crash via a specially crafted archive.

CVSS 7.5 · High · EPSS 4.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libarchive Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.2.1-6

    Update to 3.2.1-6

  • libarchive Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.2.1-6

    Update to 3.2.1-6

  • libarchive Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.2.1-6

    Update to 3.2.1-6

  • libarchive Ubuntu:14.04:LTS

    Versions
    • 3.1.2-5ubuntu1
    • 3.1.2-7ubuntu1
    • 3.1.2-7ubuntu2
    • 3.1.2-7ubuntu2.1
    • 3.1.2-7ubuntu2.2
    • 3.1.2-7ubuntu2.3
    Affected ranges
    • ECOSYSTEM: < 3.1.2-7ubuntu2.4

    Update to 3.1.2-7ubuntu2.4

  • libarchive Ubuntu:16.04:LTS

    Versions
    • 3.1.2-11build1
    • 3.1.2-11ubuntu0.16.04.1
    • 3.1.2-11ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: < 3.1.2-11ubuntu0.16.04.3

    Update to 3.1.2-11ubuntu0.16.04.3

Original sources

Check your server →