p PatchFirst

CVE-2017-5648

CVE-2017-5648

This page contains facts from public vulnerability sources. Check the original advisory before updating.

While investigating bug 60718, it was noticed that some calls to application listeners in Apache Tomcat 9.0.0.M1 to 9.0.0.M17, 8.5.0 to 8.5.11, 8.0.0.RC1 to 8.0.41, and 7.0.0 to 7.0.75 did not use the appropriate facade object. When running an untrusted application under a SecurityManager, it was therefore possible for that untrusted application to retain a reference to the request or response object and thereby access and/or modify information associated with another web application.

CVSS 9.1 · Critical · EPSS 13.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache tomcat

    Versions
    • 9.0.0.M1 to 9.0.0.M17: Affected
    • 8.5.0 to 8.5.11: Affected
    • 8.0.0.RC1 to 8.0.41: Affected
    • 7.0.0 to 7.0.75: Affected

    No fix published

  • tomcat7 Ubuntu:14.04:LTS

    Versions
    • 7.0.42-1
    • 7.0.47-1
    • 7.0.50-1
    • 7.0.52-1
    • 7.0.52-1ubuntu0.1
    • 7.0.52-1ubuntu0.3
    • 7.0.52-1ubuntu0.6
    • 7.0.52-1ubuntu0.7
    • 7.0.52-1ubuntu0.8
    • 7.0.52-1ubuntu0.9
    • 7.0.52-1ubuntu0.10
    • 7.0.52-1ubuntu0.11
    Affected ranges
    • ECOSYSTEM: < 7.0.52-1ubuntu0.13

    Update to 7.0.52-1ubuntu0.13

  • tomcat8 Ubuntu:16.04:LTS

    Versions
    • 8.0.26-1
    • 8.0.28-1
    • 8.0.30-1
    • 8.0.32-1
    • 8.0.32-1ubuntu1
    • 8.0.32-1ubuntu1.1
    • 8.0.32-1ubuntu1.2
    • 8.0.32-1ubuntu1.3
    • 8.0.32-1ubuntu1.4
    Affected ranges
    • ECOSYSTEM: < 8.0.32-1ubuntu1.5

    Update to 8.0.32-1ubuntu1.5

  • tomcat7 Ubuntu:Pro:16.04:LTS

    Versions
    • 7.0.64-1
    • 7.0.68-1
    • 7.0.68-1ubuntu0.1
    • 7.0.68-1ubuntu0.3
    • 7.0.68-1ubuntu0.4
    • 7.0.68-1ubuntu0.4+esm1
    • 7.0.68-1ubuntu0.4+esm2
    • 7.0.68-1ubuntu0.4+esm3
    • 7.0.68-1ubuntu0.4+esm4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →