CVE-2017-6418
CVE-2017-6418
This page contains facts from public vulnerability sources. Check the original advisory before updating.
libclamav/message.c in ClamAV 0.99.2 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted e-mail message.
CVSS 5.5 · Medium · EPSS 1.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
clamav Debian:12
- Affected ranges
- ECOSYSTEM: < 0.99.3~beta1+dfsg-1
Update to 0.99.3~beta1+dfsg-1
clamav Debian:13
- Affected ranges
- ECOSYSTEM: < 0.99.3~beta1+dfsg-1
Update to 0.99.3~beta1+dfsg-1
clamav Debian:14
- Affected ranges
- ECOSYSTEM: < 0.99.3~beta1+dfsg-1
Update to 0.99.3~beta1+dfsg-1
clamav Ubuntu:14.04:LTS
- Versions
- 0.97.8+dfsg-1ubuntu4
- 0.97.8+dfsg-1ubuntu5
- 0.98.1+dfsg-1ubuntu4
- 0.98.1+dfsg-1ubuntu5
- 0.98.1+dfsg-2ubuntu2
- 0.98.1+dfsg-4ubuntu1
- 0.98.1+dfsg-4ubuntu1.1
- 0.98.5+addedllvm-0ubuntu0.14.04.1
- 0.98.6+dfsg-0ubuntu0.14.04.1
- 0.98.7+dfsg-0ubuntu0.14.04.1
- 0.99.2+addedllvm-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 0.99.2+addedllvm-0ubuntu0.14.04.2
Update to 0.99.2+addedllvm-0ubuntu0.14.04.2
clamav Ubuntu:16.04:LTS
- Versions
- 0.98.7+dfsg-0ubuntu4
- 0.98.7+dfsg-0ubuntu5
- 0.99+dfsg-1ubuntu1
- 0.99+dfsg-1ubuntu1.1
- 0.99+dfsg-1ubuntu1.2
- 0.99.2+dfsg-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 0.99.2+dfsg-0ubuntu0.16.04.2
Update to 0.99.2+dfsg-0ubuntu0.16.04.2
Original sources
- https://github.com/varsleak/varsleak-vul/blob/master/clamav-vul/heap-overflow/clamav_email_crash.md
- https://bugzilla.clamav.net/show_bug.cgi?id=11797
- http://www.securityfocus.com/bid/100154
- https://github.com/vrtadmin/clamav-devel/commit/586a5180287262070637c8943f2f7efd652e4a2c
- https://security.gentoo.org/glsa/201804-16
- https://nvd.nist.gov/vuln/detail/CVE-2017-6418