CVE-2017-6590
CVE-2017-6590
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in network-manager-applet (aka network-manager-gnome) in Ubuntu 12.04 LTS, 14.04 LTS, 16.04 LTS, and 16.10. A local attacker could use this issue at the default Ubuntu login screen to access local files and execute arbitrary commands as the lightdm user. The exploitation requires physical access to the locked computer and the Wi-Fi must be turned on. An access point that lets you use a certificate to login is required as well, but it's easy to create one. Then, it's possible to open a nautilus window and browse directories. One also can open some applications such as Firefox, which is useful for downloading malicious binaries.
CVSS 6.3 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
network-manager-applet Debian:12
- Versions
- 1.30.0-2
- 1.32.0-1
- 1.32.0-2
- 1.32.0-3
- 1.34.0-1
- 1.34.0-2
- 1.36.0-1
- 1.36.0-3
- 1.36.0-4
- 1.36.0-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
network-manager-applet Debian:13
- Versions
- 1.36.0-3
- 1.36.0-4
- 1.36.0-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
network-manager-applet Debian:14
- Versions
- 1.36.0-3
- 1.36.0-4
- 1.36.0-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
network-manager-applet Ubuntu:14.04:LTS
- Versions
- 0.9.8.0-1ubuntu5
- 0.9.8.0-1ubuntu6
- 0.9.8.0-1ubuntu7
- 0.9.8.4-1ubuntu1
- 0.9.8.4-1ubuntu2
- 0.9.8.4-1ubuntu3
- 0.9.8.8-0ubuntu1
- 0.9.8.8-0ubuntu2
- 0.9.8.8-0ubuntu3
- 0.9.8.8-0ubuntu4
- 0.9.8.8-0ubuntu4.1
- 0.9.8.8-0ubuntu4.2
- 0.9.8.8-0ubuntu4.3
- 0.9.8.8-0ubuntu4.4
- Affected ranges
- ECOSYSTEM: < 0.9.8.8-0ubuntu4.5
Update to 0.9.8.8-0ubuntu4.5
network-manager-applet Ubuntu:16.04:LTS
- Versions
- 0.9.10.1-0ubuntu7
- 1.0.4-0ubuntu1
- 1.0.6-2ubuntu2
- 1.0.6-2ubuntu3
- 1.0.6-2ubuntu4
- 1.0.10-1ubuntu1
- 1.1.93-1ubuntu1
- 1.2.0-0ubuntu0.16.04.1
- 1.2.0-0ubuntu0.16.04.3
- 1.2.0-0ubuntu0.16.04.4
- 1.2.6-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 1.2.6-0ubuntu0.16.04.2
Update to 1.2.6-0ubuntu0.16.04.2