CVE-2017-6814
CVE-2017-6814
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In WordPress before 4.7.3, there is authenticated Cross-Site Scripting (XSS) via Media File Metadata. This is demonstrated by both (1) mishandling of the playlist shortcode in the wp_playlist_shortcode function in wp-includes/media.php and (2) mishandling of meta information in the renderTracks function in wp-includes/js/mediaelement/wp-playlist.js.
CVSS 5.4 · Medium · EPSS 2.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.7.3+dfsg-1
Update to 4.7.3+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.7.3+dfsg-1
Update to 4.7.3+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.7.3+dfsg-1
Update to 4.7.3+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/WordPress/WordPress/commit/28f838ca3ee205b6f39cd2bf23eb4e5f52796bd7
- http://www.securitytracker.com/id/1037959
- http://www.debian.org/security/2017/dsa-3815
- https://wpvulndb.com/vulnerabilities/8765
- http://www.securityfocus.com/bid/96601
- https://sumofpwn.nl/advisory/2016/wordpress_audio_playlist_functionality_is_affected_by_cross_site_scripting.html
- https://wordpress.org/news/2017/03/wordpress-4-7-3-security-and-maintenance-release/
- http://openwall.com/lists/oss-security/2017/03/06/8
- https://codex.wordpress.org/Version_4.7.3
- https://nvd.nist.gov/vuln/detail/CVE-2017-6814