CVE-2017-6927
CVE-2017-6927
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.
CVSS 6.1 · Medium · EPSS 1.6% · Fix available
- Published
- Updated
Affected products and versions
drupal core
- Versions
- 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57: Affected
No fix published
drupal/core Packagist
- Versions
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- Affected ranges
- ECOSYSTEM: ≥ 8.4.0, < 8.4.5
Update to 8.4.5
drupal/core Packagist
- Affected ranges
- ECOSYSTEM: ≥ 7.0, < 7.57
Update to 7.57
drupal/drupal Packagist
- Versions
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- Affected ranges
- ECOSYSTEM: ≥ 8.4.0, < 8.4.5
Update to 8.4.5
drupal/drupal Packagist
- Affected ranges
- ECOSYSTEM: ≥ 7.0, < 7.57
Update to 7.57
drupal7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- 7.26-1ubuntu0.1+esm1
- 7.26-1ubuntu0.1+esm2
- 7.26-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
drupal7 Ubuntu:Pro:16.04:LTS
- Versions
- 7.38-1
- 7.41-1
- 7.44-1ubuntu1~16.04.0
- 7.44-1ubuntu1~16.04.0+esm1
- 7.44-1ubuntu1~16.04.0+esm2
- 7.44-1ubuntu1~16.04.0+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published