CVE-2017-6928
CVE-2017-6928
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Drupal core 7.x versions before 7.57 when using Drupal's private file system, Drupal will check to make sure a user has access to a file before allowing the user to view or download it. This check fails under certain conditions in which one module is trying to grant access to the file and another is trying to deny it, leading to an access bypass vulnerability. This vulnerability is mitigated by the fact that it only occurs for unusual site configurations.
CVSS 5.3 · Medium · EPSS 1.0% · Fix available
- Published
- Updated
Affected products and versions
drupal core
- Versions
- Drupal 7.x versions before 7.57: Affected
No fix published
drupal/core Packagist
- Affected ranges
- ECOSYSTEM: ≥ 7.0, < 7.57
Update to 7.57
drupal/drupal Packagist
- Affected ranges
- ECOSYSTEM: ≥ 7.0, < 7.57
Update to 7.57
drupal7 Ubuntu:Pro:14.04:LTS
- Versions
- 7.23-1
- 7.24-1
- 7.24-2
- 7.26-1
- 7.26-1ubuntu0.1
- 7.26-1ubuntu0.1+esm1
- 7.26-1ubuntu0.1+esm2
- 7.26-1ubuntu0.1+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
drupal7 Ubuntu:Pro:16.04:LTS
- Versions
- 7.38-1
- 7.41-1
- 7.44-1ubuntu1~16.04.0
- 7.44-1ubuntu1~16.04.0+esm1
- 7.44-1ubuntu1~16.04.0+esm2
- 7.44-1ubuntu1~16.04.0+esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published