CVE-2017-6931
CVE-2017-6931
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.
CVSS 6.5 · Medium · EPSS 1.1% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
drupal core
- Versions
- 8.4.x versions before 8.4.5: Affected
No fix published
drupal/core Packagist
- Versions
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- Affected ranges
- ECOSYSTEM: ≥ 8.4.0, < 8.4.5
Update to 8.4.5
drupal/drupal Packagist
- Versions
- 8.4.0
- 8.4.1
- 8.4.2
- 8.4.3
- 8.4.4
- Affected ranges
- ECOSYSTEM: ≥ 8.4.0, < 8.4.5
Update to 8.4.5