CVE-2017-7494
CVE-2017-7494
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Samba since version 3.5.0 and before 4.6.4, 4.5.10 and 4.4.14 is vulnerable to remote code execution vulnerability, allowing a malicious client to upload a shared library to a writable share, and then cause the server to load and execute it.
CVSS 9.8 · Critical · EPSS 99.4% · In KEV · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
samba
- Versions
- since 3.5.0: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.5.8+dfsg-2
Update to 2:4.5.8+dfsg-2
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.5.8+dfsg-2
Update to 2:4.5.8+dfsg-2
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.5.8+dfsg-2
Update to 2:4.5.8+dfsg-2
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- 2:4.3.8+dfsg-0ubuntu0.14.04.2
- 2:4.3.9+dfsg-0ubuntu0.14.04.1
- 2:4.3.9+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.1
- 2:4.3.11+dfsg-0ubuntu0.14.04.2
- 2:4.3.11+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.4
- 2:4.3.11+dfsg-0ubuntu0.14.04.6
- 2:4.3.11+dfsg-0ubuntu0.14.04.7
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.14.04.8
Update to 2:4.3.11+dfsg-0ubuntu0.14.04.8
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- 2:4.3.8+dfsg-0ubuntu1
- 2:4.3.9+dfsg-0ubuntu0.16.04.1
- 2:4.3.9+dfsg-0ubuntu0.16.04.2
- 2:4.3.9+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.1
- 2:4.3.11+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.5
- 2:4.3.11+dfsg-0ubuntu0.16.04.6
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.16.04.7
Update to 2:4.3.11+dfsg-0ubuntu0.16.04.7
Original sources
- http://www.securityfocus.com/bid/98636
- http://www.debian.org/security/2017/dsa-3860
- https://www.exploit-db.com/exploits/42084/
- https://access.redhat.com/errata/RHSA-2017:1270
- https://www.samba.org/samba/security/CVE-2017-7494.html
- https://download.schneider-electric.com/files?p_enDocType=Technical+leaflet&p_File_Name=SEVD-2018-095-01+Security+Notification+Umotion+V1.1.pdf&p_Doc_Ref=SEVD-2018-095-01
- https://access.redhat.com/errata/RHSA-2017:1390
- http://www.securitytracker.com/id/1038552
- https://access.redhat.com/errata/RHSA-2017:1273
- https://access.redhat.com/errata/RHSA-2017:1271
- https://security.gentoo.org/glsa/201805-07
- https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbux03759en_us
- https://access.redhat.com/errata/RHSA-2017:1272
- https://security.netapp.com/advisory/ntap-20170524-0001/
- https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbns03755en_us
- https://www.exploit-db.com/exploits/42060/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2017-7494
- https://nvd.nist.gov/vuln/detail/CVE-2017-7494