p PatchFirst

CVE-2017-7559

CVE-2017-7559

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

CVSS 6.1 · Medium · EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • undertow

    Versions
    • 2.x before 2.0.0.Alpha2: Affected
    • 1.4.x before 1.4.17.Final: Affected
    • 1.3.x before 1.3.31.Final: Affected

    No fix published

  • undertow Debian:14

    Versions
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.19-1
    • 1.3.21-1
    • 1.3.23-1
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.18-1
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.21-2
    • 1.4.22-1
    • 1.4.3-1
    • 1.4.4-1
    • 1.4.6-1
    • 1.4.7-1
    • 1.4.8-1
    Affected ranges
    • ECOSYSTEM: < 1.4.23-1

    Update to 1.4.23-1

  • undertow Ubuntu:Pro:16.04:LTS

    Versions
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.16-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • undertow Ubuntu:Pro:24.04:LTS

    Versions
    • 2.3.8-2
    • 2.3.8-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →