p PatchFirst

CVE-2017-7897

CVE-2017-7897

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A cross-site scripting (XSS) vulnerability in the MantisBT (2.3.x before 2.3.2) Timeline include page, used in My View (my_view_page.php) and User Information (view_user_page.php) pages, allows remote attackers to inject arbitrary code (if CSP settings permit it) through crafted PATH_INFO in a URL, due to use of unsanitized $_SERVER['PHP_SELF'] to generate URLs.

CVSS 6.1 · Medium · EPSS 1.8% · Fix available

Published
Updated

Stack: php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mantisbt/mantisbt Packagist

    Versions
    • 2.3.0
    • 2.3.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.3.0, < 2.3.2

    Update to 2.3.2

Original sources

Check your server →