CVE-2017-9066
CVE-2017-9066
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In WordPress before 4.7.5, there is insufficient redirect validation in the HTTP class, leading to SSRF.
CVSS 8.6 · High · EPSS 3.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.7.5+dfsg-1
Update to 4.7.5+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.7.5+dfsg-1
Update to 4.7.5+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.7.5+dfsg-1
Update to 4.7.5+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.debian.org/security/2018/dsa-4090
- http://www.securitytracker.com/id/1038520
- https://wpvulndb.com/vulnerabilities/8815
- https://wordpress.org/news/2017/05/wordpress-4-7-5/
- http://www.securityfocus.com/bid/98509
- https://twitter.com/skansing/status/865362551097393153
- https://github.com/WordPress/WordPress/commit/76d77e927bb4d0f87c7262a50e28d84e01fd2b11
- https://codex.wordpress.org/Version_4.7.5
- https://nvd.nist.gov/vuln/detail/CVE-2017-9066