CVE-2018-0202
CVE-2018-0202
This page contains facts from public vulnerability sources. Check the original advisory before updating.
clamscan in ClamAV before 0.99.4 contains a vulnerability that could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to improper input validation checking mechanisms when handling Portable Document Format (.pdf) files sent to an affected device. An unauthenticated, remote attacker could exploit this vulnerability by sending a crafted .pdf file to an affected device. This action could cause an out-of-bounds read when ClamAV scans the malicious file, allowing the attacker to cause a DoS condition. This concerns pdf_parse_array and pdf_parse_string in libclamav/pdfng.c. Cisco Bug IDs: CSCvh91380, CSCvh91400.
CVSS 5.5 · Medium · EPSS 2.6% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
clamav
- Versions
- ClamAV: Affected
No fix published
clamav Debian:12
- Affected ranges
- ECOSYSTEM: < 0.100.0~beta+dfsg-2
Update to 0.100.0~beta+dfsg-2
clamav Debian:13
- Affected ranges
- ECOSYSTEM: < 0.100.0~beta+dfsg-2
Update to 0.100.0~beta+dfsg-2
clamav Debian:14
- Affected ranges
- ECOSYSTEM: < 0.100.0~beta+dfsg-2
Update to 0.100.0~beta+dfsg-2
clamav Ubuntu:14.04:LTS
- Versions
- 0.97.8+dfsg-1ubuntu4
- 0.97.8+dfsg-1ubuntu5
- 0.98.1+dfsg-1ubuntu4
- 0.98.1+dfsg-1ubuntu5
- 0.98.1+dfsg-2ubuntu2
- 0.98.1+dfsg-4ubuntu1
- 0.98.1+dfsg-4ubuntu1.1
- 0.98.5+addedllvm-0ubuntu0.14.04.1
- 0.98.6+dfsg-0ubuntu0.14.04.1
- 0.98.7+dfsg-0ubuntu0.14.04.1
- 0.99.2+addedllvm-0ubuntu0.14.04.1
- 0.99.2+addedllvm-0ubuntu0.14.04.2
- 0.99.3+addedllvm-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 0.99.4+addedllvm-0ubuntu0.14.04.1
Update to 0.99.4+addedllvm-0ubuntu0.14.04.1
clamav Ubuntu:16.04:LTS
- Versions
- 0.98.7+dfsg-0ubuntu4
- 0.98.7+dfsg-0ubuntu5
- 0.99+dfsg-1ubuntu1
- 0.99+dfsg-1ubuntu1.1
- 0.99+dfsg-1ubuntu1.2
- 0.99.2+dfsg-0ubuntu0.16.04.1
- 0.99.2+dfsg-0ubuntu0.16.04.2
- 0.99.2+dfsg-0ubuntu0.16.04.3
- 0.99.3+addedllvm-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 0.99.4+addedllvm-0ubuntu0.16.04.1
Update to 0.99.4+addedllvm-0ubuntu0.16.04.1
Original sources
- https://usn.ubuntu.com/3592-2/
- https://bugzilla.clamav.net/show_bug.cgi?id=11973
- https://bugzilla.clamav.net/show_bug.cgi?id=11980
- https://lists.debian.org/debian-lts-announce/2018/03/msg00011.html
- https://usn.ubuntu.com/3592-1/
- https://security.gentoo.org/glsa/201804-16
- https://nvd.nist.gov/vuln/detail/CVE-2018-0202