p PatchFirst

CVE-2018-0494

CVE-2018-0494

This page contains facts from public vulnerability sources. Check the original advisory before updating.

GNU Wget before 1.19.5 is prone to a cookie injection vulnerability in the resp_new function in http.c via a \r\n sequence in a continuation line.

CVSS 6.5 · Medium · EPSS 16.5% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • wget

    Versions
    • WGet: Affected

    No fix published

  • wget Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.19.5-1

    Update to 1.19.5-1

  • wget Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.19.5-1

    Update to 1.19.5-1

  • wget Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.19.5-1

    Update to 1.19.5-1

  • wget Ubuntu:14.04:LTS

    Versions
    • 1.14-2ubuntu1
    • 1.14-5ubuntu1
    • 1.15-1ubuntu1
    • 1.15-1ubuntu1.14.04.1
    • 1.15-1ubuntu1.14.04.2
    • 1.15-1ubuntu1.14.04.3
    Affected ranges
    • ECOSYSTEM: < 1.15-1ubuntu1.14.04.4

    Update to 1.15-1ubuntu1.14.04.4

  • wget Ubuntu:16.04:LTS

    Versions
    • 1.16.1-1ubuntu1
    • 1.17.1-1ubuntu1
    • 1.17.1-1ubuntu1.1
    • 1.17.1-1ubuntu1.2
    • 1.17.1-1ubuntu1.3
    Affected ranges
    • ECOSYSTEM: < 1.17.1-1ubuntu1.4

    Update to 1.17.1-1ubuntu1.4

  • wget Ubuntu:18.04:LTS

    Versions
    • 1.19.1-3ubuntu1
    • 1.19.1-3ubuntu1.1
    • 1.19.2-1ubuntu1
    • 1.19.3-2ubuntu1
    • 1.19.4-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.19.4-1ubuntu2.1

    Update to 1.19.4-1ubuntu2.1

Original sources

Check your server →