p PatchFirst

CVE-2018-1000164

CVE-2018-1000164

This page contains facts from public vulnerability sources. Check the original advisory before updating.

gunicorn version 19.4.5 contains a CWE-113: Improper Neutralization of CRLF Sequences in HTTP Headers vulnerability in "process_headers" function in "gunicorn/http/wsgi.py" that can result in an attacker causing the server to return arbitrary HTTP headers. This vulnerability appears to have been fixed in 19.5.0.

CVSS 8.7 · High · EPSS 2.4% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • gunicorn Debian:12

    Affected ranges
    • ECOSYSTEM: < 19.5.0-1

    Update to 19.5.0-1

  • gunicorn Debian:13

    Affected ranges
    • ECOSYSTEM: < 19.5.0-1

    Update to 19.5.0-1

  • gunicorn Debian:14

    Affected ranges
    • ECOSYSTEM: < 19.5.0-1

    Update to 19.5.0-1

  • gunicorn PyPI

    Versions
    • 0.1
    • 0.10.0
    • 0.10.1
    • 0.11.0
    • 0.11.1
    • 0.11.2
    • 0.12.0
    • 0.12.1
    • 0.12.2
    • 0.13.0
    • 0.13.1
    • 0.13.2
    • 0.13.3
    • 0.13.4
    • 0.14.0
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.14.4
    • 0.14.5
    • 0.14.6
    • 0.15.0
    • 0.16.0
    • 0.16.1
    • 0.17.0
    • 0.17.1
    • 0.17.2
    • 0.17.3
    • 0.17.4
    • 0.2
    • 0.2.1
    • 0.3
    • 0.3.1
    • 0.3.2
    • 0.4
    • 0.4.1
    • 0.4.2
    • 0.5
    • 0.5.1
    • 0.6
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.6.4
    • 0.6.5
    • 0.6.6
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.8.1
    • 0.9.0
    • 0.9.1
    • 17.5
    • 18.0
    • 19.0.0
    • 19.1.0
    • 19.1.1
    • 19.2.0
    • 19.2.1
    • 19.3.0
    • 19.4.0
    • 19.4.1
    • 19.4.2
    • 19.4.3
    • 19.4.4
    • 19.4.5
    Affected ranges
    • ECOSYSTEM: < 19.5.0

    Update to 19.5.0

  • gunicorn Ubuntu:Pro:14.04:LTS

    Versions
    • 17.5-2
    • 17.5-2build1
    Affected ranges
    • ECOSYSTEM: < 17.5-2ubuntu0.1~esm1

    Update to 17.5-2ubuntu0.1~esm1

  • gunicorn Ubuntu:16.04:LTS

    Versions
    • 19.0-8ubuntu1
    • 19.4.1-1ubuntu1
    • 19.4.5-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 19.4.5-1ubuntu1.1

    Update to 19.4.5-1ubuntu1.1

Original sources

Check your server →