CVE-2018-10102
CVE-2018-10102
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Before WordPress 4.9.5, the version string was not escaped in the get_the_generator function, and could lead to XSS in a generator tag.
CVSS 6.1 · Medium · EPSS 4.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.9.5+dfsg1-1
Update to 4.9.5+dfsg1-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.9.5+dfsg1-1
Update to 4.9.5+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.9.5+dfsg1-1
Update to 4.9.5+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.securityfocus.com/bid/103775
- https://wpvulndb.com/vulnerabilities/9055
- http://www.securitytracker.com/id/1040836
- https://www.debian.org/security/2018/dsa-4193
- https://core.trac.wordpress.org/changeset/42893
- https://wordpress.org/news/2018/04/wordpress-4-9-5-security-and-maintenance-release/
- https://lists.debian.org/debian-lts-announce/2018/04/msg00031.html
- https://codex.wordpress.org/Version_4.9.5
- https://github.com/WordPress/WordPress/commit/31a4369366d6b8ce30045d4c838de2412c77850d
- https://nvd.nist.gov/vuln/detail/CVE-2018-10102