p PatchFirst

CVE-2018-10191

CVE-2018-10191

This page contains facts from public vulnerability sources. Check the original advisory before updating.

In versions of mruby up to and including 1.4.0, an integer overflow exists in src/vm.c::mrb_vm_exec() when handling OP_GETUPVAR in the presence of deep scope nesting, resulting in a use-after-free. An attacker that can cause Ruby code to be run can use this to possibly execute arbitrary code.

CVSS 9.8 · Critical · EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • mruby Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.4.0+20180418+git54905e98-1

    Update to 1.4.0+20180418+git54905e98-1

  • mruby Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.4.0+20180418+git54905e98-1

    Update to 1.4.0+20180418+git54905e98-1

  • mruby Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.4.0+20180418+git54905e98-1

    Update to 1.4.0+20180418+git54905e98-1

  • mruby Ubuntu:16.04:LTS

    Versions
    • 1.1.0+20150817+gita1731254-1
    • 1.1.0+20150906+git1cbbb7e1-1
    • 1.2.0+20160315+git4f20d58a-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • mruby Ubuntu:18.04:LTS

    Versions
    • 1.3.0-1
    • 1.3.0+20170925+git38185028-1
    • 1.3.0+20171029+git77edafb0-1
    • 1.4.0-1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →