CVE-2018-1042
CVE-2018-1042
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Moodle 3.x has Server Side Request Forgery in the filepicker.
CVSS 6.5 · Medium · EPSS 16.2% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
moodle 3.x
- Versions
- Moodle 3.x: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.4.0
- v3.4.0-beta
- v3.4.0-rc1
- v3.4.0-rc2
- v3.4.0-rc3
- Affected ranges
- ECOSYSTEM: ≥ 3.4, < 3.4.1
Update to 3.4.1
moodle/moodle Packagist
- Versions
- v3.3.0
- v3.3.0-beta
- v3.3.0-rc1
- v3.3.0-rc2
- v3.3.0-rc3
- v3.3.1
- v3.3.2
- v3.3.3
- Affected ranges
- ECOSYSTEM: ≥ 3.3, < 3.3.4
Update to 3.3.4
moodle/moodle Packagist
- Versions
- v3.2.0
- v3.2.0-beta
- v3.2.0-rc1
- v3.2.0-rc2
- v3.2.0-rc3
- v3.2.0-rc4
- v3.2.0-rc5
- v3.2.1
- v3.2.2
- v3.2.3
- v3.2.4
- v3.2.5
- v3.2.6
- Affected ranges
- ECOSYSTEM: ≥ 3.2, < 3.2.7
Update to 3.2.7
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.0-beta
- v3.1.0-rc1
- v3.1.0-rc2
- v3.1.1
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- v3.1.6
- v3.1.7
- v3.1.8
- v3.1.9
- Affected ranges
- ECOSYSTEM: ≥ 3.1, < 3.1.10
Update to 3.1.10
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published