CVE-2018-10548
CVE-2018-10548
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in PHP before 5.6.36, 7.0.x before 7.0.30, 7.1.x before 7.1.17, and 7.2.x before 7.2.5. ext/ldap/ldap.c allows remote LDAP servers to cause a denial of service (NULL pointer dereference and application crash) because of mishandling of the ldap_get_dn return value.
CVSS 7.5 · High · EPSS 8.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php5 Ubuntu:14.04:LTS
- Versions
- 5.5.3+dfsg-1ubuntu2
- 5.5.3+dfsg-1ubuntu3
- 5.5.6+dfsg-1ubuntu1
- 5.5.6+dfsg-1ubuntu2
- 5.5.8+dfsg-2ubuntu1
- 5.5.9+dfsg-1ubuntu1
- 5.5.9+dfsg-1ubuntu2
- 5.5.9+dfsg-1ubuntu3
- 5.5.9+dfsg-1ubuntu4
- 5.5.9+dfsg-1ubuntu4.1
- 5.5.9+dfsg-1ubuntu4.2
- 5.5.9+dfsg-1ubuntu4.3
- 5.5.9+dfsg-1ubuntu4.4
- 5.5.9+dfsg-1ubuntu4.5
- 5.5.9+dfsg-1ubuntu4.6
- 5.5.9+dfsg-1ubuntu4.7
- 5.5.9+dfsg-1ubuntu4.9
- 5.5.9+dfsg-1ubuntu4.11
- 5.5.9+dfsg-1ubuntu4.12
- 5.5.9+dfsg-1ubuntu4.13
- 5.5.9+dfsg-1ubuntu4.14
- 5.5.9+dfsg-1ubuntu4.16
- 5.5.9+dfsg-1ubuntu4.17
- 5.5.9+dfsg-1ubuntu4.19
- 5.5.9+dfsg-1ubuntu4.20
- 5.5.9+dfsg-1ubuntu4.21
- 5.5.9+dfsg-1ubuntu4.22
- 5.5.9+dfsg-1ubuntu4.23
- 5.5.9+dfsg-1ubuntu4.24
- Affected ranges
- ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.25
Update to 5.5.9+dfsg-1ubuntu4.25
php7.0 Ubuntu:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.2
- 7.0.15-0ubuntu0.16.04.4
- 7.0.18-0ubuntu0.16.04.1
- 7.0.22-0ubuntu0.16.04.1
- 7.0.25-0ubuntu0.16.04.1
- 7.0.28-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 7.0.30-0ubuntu0.16.04.1
Update to 7.0.30-0ubuntu0.16.04.1
php7.2 Ubuntu:18.04:LTS
- Versions
- 7.2.1-1ubuntu2
- 7.2.2-1ubuntu1
- 7.2.2-1ubuntu2
- 7.2.3-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 7.2.5-0ubuntu0.18.04.1
Update to 7.2.5-0ubuntu0.18.04.1
Original sources
- http://www.securityfocus.com/bid/104019
- http://www.securitytracker.com/id/1040807
- https://usn.ubuntu.com/3646-2/
- https://bugs.php.net/bug.php?id=76248
- https://www.debian.org/security/2018/dsa-4240
- https://www.tenable.com/security/tns-2018-12
- https://usn.ubuntu.com/3646-1/
- http://php.net/ChangeLog-5.php
- https://lists.debian.org/debian-lts-announce/2018/05/msg00004.html
- http://php.net/ChangeLog-7.php
- https://security.gentoo.org/glsa/201812-01
- https://security.netapp.com/advisory/ntap-20180607-0003/
- https://lists.debian.org/debian-lts-announce/2018/06/msg00005.html
- https://access.redhat.com/errata/RHSA-2019:2519
- https://www.tenable.com/security/tns-2019-07
- https://nvd.nist.gov/vuln/detail/CVE-2018-10548